What’s Vulnerable › Vulnerabilities
CVE-2020-28502: Arbitrary Code Injection
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-03-05 · updated 2026-06-17
- Weakness: CWE-94
Description
This affects the package xmlhttprequest before 1.7.0; all versions of package xmlhttprequest-ssl. Provided requests are sent synchronously (async=False on xhr.open), malicious user input flowing into xhr.send could result in arbitrary code being injected and run.
Affected products
- Xmlhttprequest Project Xmlhttprequest: before 1.7.0 — fixed in 1.7.0
How to fix
Upgrade to a fixed version: Xmlhttprequest Project Xmlhttprequest 1.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/driverdan/node-XMLHttpRequest/blob/1.6.0/lib/XMLHttpRequest.js%23L480
- https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-1082937
- https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-1082938
- https://snyk.io/vuln/SNYK-JS-XMLHTTPREQUEST-1082935
- https://snyk.io/vuln/SNYK-JS-XMLHTTPREQUESTSSL-1082936
- https://github.com/driverdan/node-XMLHttpRequest/blob/1.6.0/lib/XMLHttpRequest.js%23L480
- https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-1082937
- https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-1082938
- https://snyk.io/vuln/SNYK-JS-XMLHTTPREQUEST-1082935
- https://snyk.io/vuln/SNYK-JS-XMLHTTPREQUESTSSL-1082936
Get alerted when CVE-2020-28502 or the next vulnerability affects your stack