What’s Vulnerable › Vulnerabilities
CVE-2020-28707
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-01-19 · updated 2026-07-09
- Weakness: CWE-79
Description
The Stockdio Historical Chart plugin before 2.8.1 for WordPress is affected by Cross Site Scripting (XSS) via stockdio_chart_historical-wp.js in wp-content/plugins/stockdio-historical-chart/assets/ because the origin of a postMessage() event is not validated. The stockdio_eventer function listens for any postMessage event. After a message event is sent to the application, this function sets the "e" variable as the event and checks that the types of the data and data.method are not undefined (empty) before proceeding to eval the data.method received from the postMessage. However, on a different website. JavaScript code can call window.open for the vulnerable WordPress instance and do a postMessage(msg,'*') for that object.
Affected products
- Stockdio Historical Chart: before 2.8.1 — fixed in 2.8.1
How to fix
Upgrade to a fixed version: Stockdio Historical Chart 2.8.1. Check the vendor advisory for mitigations.
References
- https://jondow.eu/cve-2020-28707-xss-in-stockdio-historical-chart-plugin-for-wordpress-before-version-281/
- https://wordpress.org/plugins/stockdio-historical-chart/#developers
- https://jondow.eu/cve-2020-28707-xss-in-stockdio-historical-chart-plugin-for-wordpress-before-version-281/
- https://wordpress.org/plugins/stockdio-historical-chart/#developers
Get alerted when CVE-2020-28707 or the next vulnerability affects your stack