What’s Vulnerable › Vulnerabilities
CVE-2020-28840
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-08-11 · updated 2026-06-17
- Weakness: CWE-120
Description
Buffer Overflow vulnerability in jpgfile.c in Matthias-Wandel jhead version 3.04, allows local attackers to execute arbitrary code and cause a denial of service (DoS).
Affected products
- Matthiaswandel Jhead: before 3.04 — fixed in 3.04
How to fix
Upgrade to a fixed version: Matthiaswandel Jhead 3.04. Check the vendor advisory for mitigations.
References
- https://bugs.launchpad.net/ubuntu/+source/jhead/+bug/1900820
- https://github.com/F-ZhaoYang/jhead/security/advisories/GHSA-xh27-xwgj-gqw2
- https://github.com/Matthias-Wandel/jhead/commit/4827ed31c226dc5ed93603bd649e0e387a1778da
- https://github.com/Matthias-Wandel/jhead/issues/8
- https://bugs.launchpad.net/ubuntu/+source/jhead/+bug/1900820
- https://github.com/F-ZhaoYang/jhead/security/advisories/GHSA-xh27-xwgj-gqw2
- https://github.com/Matthias-Wandel/jhead/commit/4827ed31c226dc5ed93603bd649e0e387a1778da
- https://github.com/Matthias-Wandel/jhead/issues/8
Get alerted when CVE-2020-28840 or the next vulnerability affects your stack