What’s Vulnerable › Vulnerabilities
CVE-2020-28899
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-16 · updated 2026-06-17
- Weakness: CWE-306
Description
The Web CGI Script on ZyXEL LTE4506-M606 V1.00(ABDO.2)C0 devices does not require authentication, which allows remote unauthenticated attackers (via crafted JSON action data to /cgi-bin/gui.cgi) to use all features provided by the router. Examples: change the router password, retrieve the Wi-Fi passphrase, send an SMS message, or modify the IP forwarding to access the internal network.
Affected products
- Zyxel Lte4506-M606 Firmware: before v1.00\(abdo.6\)c0 — fixed in v1.00\(abdo.6\)c0
- Zyxel Lte7460-M608 Firmware: before v1.00\(abfr.5\)c0 — fixed in v1.00\(abfr.5\)c0
- Zyxel Wah7706 Firmware: before v1.00\(abbc.11\)c0 — fixed in v1.00\(abbc.11\)c0
How to fix
Upgrade to a fixed version: Zyxel Lte4506-M606 Firmware v1.00\(abdo.6\)c0; Zyxel Lte7460-M608 Firmware v1.00\(abfr.5\)c0; Zyxel Wah7706 Firmware v1.00\(abbc.11\)c0. Check the vendor advisory for mitigations.
References
- https://www.zyxel.com/support/Zyxel-security-advisory-for-CGI-vulnerability-of-LTE.shtml
- https://www.zyxel.com/support/Zyxel-security-advisory-for-CGI-vulnerability-of-LTE.shtml
Get alerted when CVE-2020-28899 or the next vulnerability affects your stack