What’s Vulnerable › Vulnerabilities
CVE-2020-28914
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-11-17 · updated 2026-06-17
- Weakness: CWE-732
Description
An improper file permissions vulnerability affects Kata Containers prior to 1.11.5. When using a Kubernetes hostPath volume and mounting either a file or directory into a container as readonly, the file/directory is mounted as readOnly inside the container, but is still writable inside the guest. For a container breakout situation, a malicious guest can potentially modify or delete files/directories expected to be read-only.
Affected products
- Katacontainers Kata-Containers: before 1.11.5 — fixed in 1.11.5
How to fix
Upgrade to a fixed version: Katacontainers Kata-Containers 1.11.5. Check the vendor advisory for mitigations.
References
- https://github.com/kata-containers/kata-containers/pull/1062
- https://github.com/kata-containers/runtime/pull/3042
- https://github.com/kata-containers/runtime/pull/3051
- https://github.com/kata-containers/runtime/releases/tag/1.11.5
- https://github.com/kata-containers/runtime/releases/tag/1.12.0
- https://github.com/kata-containers/kata-containers/pull/1062
- https://github.com/kata-containers/runtime/pull/3042
- https://github.com/kata-containers/runtime/pull/3051
- https://github.com/kata-containers/runtime/releases/tag/1.11.5
- https://github.com/kata-containers/runtime/releases/tag/1.12.0
Get alerted when CVE-2020-28914 or the next vulnerability affects your stack