What’s Vulnerable › Vulnerabilities
CVE-2020-28984
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-11-23 · updated 2026-06-17
Description
prive/formulaires/configurer_preferences.php in SPIP before 3.2.8 does not properly validate the couleur, display, display_navigation, display_outils, imessage, and spip_ecran parameters.
Affected products
- Debian Linux: 9.0, 10.0
- SPIP: before 3.2.8 — fixed in 3.2.8
How to fix
Upgrade to a fixed version: SPIP 3.2.8. Check the vendor advisory for mitigations.
References
- https://git.spip.net/spip/spip/commit/ae4267eba1022dabc12831ddb021c5d6e09040f8
- https://git.spip.net/spip/spip/compare/v3.2.7...v3.2.8
- https://lists.debian.org/debian-lts-announce/2020/12/msg00036.html
- https://www.debian.org/security/2020/dsa-4798
- https://git.spip.net/spip/spip/commit/ae4267eba1022dabc12831ddb021c5d6e09040f8
- https://git.spip.net/spip/spip/compare/v3.2.7...v3.2.8
- https://lists.debian.org/debian-lts-announce/2020/12/msg00036.html
- https://www.debian.org/security/2020/dsa-4798
Get alerted when CVE-2020-28984 or the next vulnerability affects your stack