What’s Vulnerable › Vulnerabilities
CVE-2020-29016
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-01-14 · updated 2026-06-17
- Weakness: CWE-787
Description
A stack-based buffer overflow vulnerability in FortiWeb 6.3.0 through 6.3.5 and version before 6.2.4 may allow an unauthenticated, remote attacker to overwrite the content of the stack and potentially execute arbitrary code by sending a crafted request with a large certname.
Affected products
- Fortinet FortiWeb: before 6.2.4; from 6.3.0 through 6.3.5 — fixed in 6.2.4
How to fix
Upgrade to a fixed version: Fortinet FortiWeb 6.2.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2020-29016 or the next vulnerability affects your stack