What’s Vulnerable › Vulnerabilities
CVE-2020-29128
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-11-26 · updated 2026-06-17
- Weakness: CWE-91
Description
petl before 1.68, in some configurations, allows resolution of entities in an XML document.
Affected products
- Petl Project Petl: before 1.6.8 — fixed in 1.6.8
How to fix
Upgrade to a fixed version: Petl Project Petl 1.6.8. Check the vendor advisory for mitigations.
References
- https://github.com/nvn1729/advisories/blob/master/cve-2020-29128.md
- https://github.com/petl-developers/petl/compare/v1.6.7...v1.6.8
- https://github.com/petl-developers/petl/issues/526
- https://github.com/petl-developers/petl/pull/527
- https://github.com/petl-developers/petl/pull/527/commits/1b0a09f08c3cdfe2e69647bd02f97c1367a5b5f8
- https://github.com/petl-developers/petl/security/advisories/GHSA-f5gc-p5m3-v347
- https://petl.readthedocs.io/en/stable/changes.html
- https://github.com/nvn1729/advisories/blob/master/cve-2020-29128.md
- https://github.com/petl-developers/petl/compare/v1.6.7...v1.6.8
- https://github.com/petl-developers/petl/issues/526
- https://github.com/petl-developers/petl/pull/527
- https://github.com/petl-developers/petl/pull/527/commits/1b0a09f08c3cdfe2e69647bd02f97c1367a5b5f8
Get alerted when CVE-2020-29128 or the next vulnerability affects your stack