What’s Vulnerable › Vulnerabilities
CVE-2020-29143
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-02-15 · updated 2026-06-17
- Weakness: CWE-89
Description
A SQL injection vulnerability in interface/reports/non_reported.php in OpenEMR before 5.0.2.5 allows a remote authenticated attacker to execute arbitrary SQL commands via the form_code parameter.
Affected products
- openemr: before 5.0.2.5 — fixed in 5.0.2.5
How to fix
Upgrade to a fixed version: openemr 5.0.2.5. Check the vendor advisory for mitigations.
References
- https://community.open-emr.org/t/openemr-6-0-0-has-been-released/15732
- https://murat.one/?p=94
- https://nitroteam.kz/index.php?action=researches&slug=OpenEMR--9035
- https://www.open-emr.org/wiki/index.php/OpenEMR_Downloads
- https://community.open-emr.org/t/openemr-6-0-0-has-been-released/15732
- https://murat.one/?p=94
- https://nitroteam.kz/index.php?action=researches&slug=OpenEMR--9035
- https://www.open-emr.org/wiki/index.php/OpenEMR_Downloads
Get alerted when CVE-2020-29143 or the next vulnerability affects your stack