What’s Vulnerable › Vulnerabilities
CVE-2020-29156
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-12-27 · updated 2026-06-17
- Weakness: CWE-639
Description
The WooCommerce plugin before 4.7.0 for WordPress allows remote attackers to view the status of arbitrary orders via the order_id parameter in a fetch_order_status action.
Affected products
- Automattic WooCommerce: before 4.7.0 — fixed in 4.7.0
How to fix
Upgrade to a fixed version: Automattic WooCommerce 4.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/Ko-kn3t/CVE-2020-29156
- https://raw.githubusercontent.com/woocommerce/woocommerce/master/changelog.txt
- https://github.com/Ko-kn3t/CVE-2020-29156
- https://raw.githubusercontent.com/woocommerce/woocommerce/master/changelog.txt
Get alerted when CVE-2020-29156 or the next vulnerability affects your stack