What’s Vulnerable › Vulnerabilities
CVE-2020-29448
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-02-22 · updated 2026-06-17
Description
The ConfluenceResourceDownloadRewriteRule class in Confluence Server and Confluence Data Center before version 6.13.18, from 6.14.0 before 7.4.6, and from 7.5.0 before 7.8.3 allowed unauthenticated remote attackers to read arbitrary files within WEB-INF and META-INF directories via an incorrect path access check.
Affected products
- Atlassian Confluence Data Center: before 6.13.18; from 6.14.0 before 7.4.6; from 7.5.0 before 7.8.3 — fixed in 6.13.18, 7.4.6, 7.8.3
- Atlassian Confluence Data Center: before 6.13.18; from 6.14.0 before 7.4.6; from 7.5.0 before 7.8.3 — fixed in 6.13.18, 7.4.6, 7.8.3
How to fix
Upgrade to a fixed version: Atlassian Confluence Data Center 6.13.18, 7.4.6, 7.8.3; Atlassian Confluence Data Center 6.13.18, 7.4.6, 7.8.3. Check the vendor advisory for mitigations.
References
- https://jira.atlassian.com/browse/CONFSERVER-60469
- https://jira.atlassian.com/browse/CONFSERVER-60469
Get alerted when CVE-2020-29448 or the next vulnerability affects your stack