What’s Vulnerable › Vulnerabilities
CVE-2020-29456
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-02 · updated 2026-06-17
- Weakness: CWE-79
Description
Multiple cross-site scripting (XSS) vulnerabilities in Papermerge before 1.5.2 allow remote attackers to inject arbitrary web script or HTML via the rename, tag, upload, or create folder function. The payload can be in a folder, a tag, or a document's filename. If email consumption is configured in Papermerge, a malicious document can be sent by email and is automatically uploaded into the Papermerge web application. Therefore, no authentication is required to exploit XSS if email consumption is configured. Otherwise authentication is required.
Affected products
- Papermerge: before 1.5.2 — fixed in 1.5.2
How to fix
Upgrade to a fixed version: Papermerge 1.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/ciur/papermerge/issues/228
- https://github.com/ciur/papermerge/releases/tag/v1.5.2
- https://www.papermerge.com/
- https://github.com/ciur/papermerge/issues/228
- https://github.com/ciur/papermerge/releases/tag/v1.5.2
- https://www.papermerge.com/
Get alerted when CVE-2020-29456 or the next vulnerability affects your stack