What’s Vulnerable › Vulnerabilities
CVE-2020-29565
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-12-04 · updated 2026-06-17
- Weakness: CWE-601
Description
An issue was discovered in OpenStack Horizon before 15.3.2, 16.x before 16.2.1, 17.x and 18.x before 18.3.3, 18.4.x, and 18.5.x. There is a lack of validation of the "next" parameter, which would allow someone to supply a malicious URL in Horizon that can cause an automatic redirect to the provided malicious URL.
Affected products
- Debian Linux: 10.0
- OpenStack Horizon: from 15.3.0 before 15.3.2; from 16.0.0 before 16.2.1; from 17.0.0 before 18.3.3; from 18.4.0 through 18.5.0 — fixed in 15.3.2, 16.2.1, 18.3.3
How to fix
Upgrade to a fixed version: OpenStack Horizon 15.3.2, 16.2.1, 18.3.3. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2020/12/08/2
- https://bugs.launchpad.net/horizon/+bug/1865026
- https://review.opendev.org/c/openstack/horizon/+/758841/
- https://review.opendev.org/c/openstack/horizon/+/758843/
- https://security.openstack.org/ossa/OSSA-2020-008.html
- https://www.debian.org/security/2020/dsa-4820
- http://www.openwall.com/lists/oss-security/2020/12/08/2
- https://bugs.launchpad.net/horizon/+bug/1865026
- https://review.opendev.org/c/openstack/horizon/+/758841/
- https://review.opendev.org/c/openstack/horizon/+/758843/
- https://security.openstack.org/ossa/OSSA-2020-008.html
- https://www.debian.org/security/2020/dsa-4820
Get alerted when CVE-2020-29565 or the next vulnerability affects your stack