What’s Vulnerable › Vulnerabilities
CVE-2020-29599
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-12-07 · updated 2026-06-17
- Weakness: CWE-91
Description
ImageMagick before 6.9.11-40 and 7.x before 7.0.10-40 mishandles the -authenticate option, which allows setting a password for password-protected PDF files. The user-controlled password was not properly escaped/sanitized and it was therefore possible to inject additional shell commands via coders/pdf.c.
Affected products
- Debian Linux: 9.0
- ImageMagick: from 6.9.8-1 before 6.9.11-40; from 7.0.5-3 before 7.0.10-40 — fixed in 6.9.11-40, 7.0.10-40
How to fix
Upgrade to a fixed version: ImageMagick 6.9.11-40, 7.0.10-40. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/discussions/2851
- https://insert-script.blogspot.com/2020/11/imagemagick-shell-injection-via-pdf.html
- https://lists.debian.org/debian-lts-announce/2021/01/msg00010.html
- https://lists.debian.org/debian-lts-announce/2023/03/msg00008.html
- https://security.gentoo.org/glsa/202101-36
- https://github.com/ImageMagick/ImageMagick/discussions/2851
- https://insert-script.blogspot.com/2020/11/imagemagick-shell-injection-via-pdf.html
- https://lists.debian.org/debian-lts-announce/2021/01/msg00010.html
- https://lists.debian.org/debian-lts-announce/2023/03/msg00008.html
- https://security.gentoo.org/glsa/202101-36
Get alerted when CVE-2020-29599 or the next vulnerability affects your stack