What’s Vulnerable › Vulnerabilities
CVE-2020-3128: Cisco Webex Network Recording Player and Cisco Webex Player Arbitrary Code Execution Vulnerabilities
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-03-04 · updated 2026-06-17
- Weakness: CWE-20
Description
Multiple vulnerabilities in Cisco Webex Network Recording Player for Microsoft Windows and Cisco Webex Player for Microsoft Windows could allow an attacker to execute arbitrary code on an affected system. The vulnerabilities are due to insufficient validation of certain elements within a Webex recording that is stored in either the Advanced Recording Format (ARF) or the Webex Recording Format (WRF). An attacker could exploit these vulnerabilities by sending a malicious ARF or WRF file to a user through a link or email attachment and persuading the user to open the file on the local system. A successful exploit could allow the attacker to execute arbitrary code on the affected system with the privileges of the targeted user.
Affected products
- Cisco Webex Meetings: from 39.5 before 39.5.17 — fixed in 39.5.17
- Cisco WebEx WRF Player: before 1.3.49 — fixed in 1.3.49
- Cisco WebEx Meetings Server: before 3.0; 3.0, 3.0-maintenance_release1, 3.0-maintenance_release2, 3.0-maintenance_release3, 4.0, 4.0-maintenance_release1 (+1) — fixed in 3.0
- Cisco Webex Network Recording Player: before 39.5.17; before 39.11.0 — fixed in 39.11.0, 39.5.17
How to fix
Upgrade to a fixed version: Cisco Webex Meetings 39.5.17; Cisco WebEx WRF Player 1.3.49; Cisco WebEx Meetings Server 3.0; Cisco Webex Network Recording Player 39.11.0, 39.5.17. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20200304-webex-player
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20200304-webex-player
Get alerted when CVE-2020-3128 or the next vulnerability affects your stack