What’s Vulnerable › Vulnerabilities
CVE-2020-3169: Cisco FXOS Software CLI Command Injection Vulnerability
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-02-26 · updated 2026-06-17
- Weakness: CWE-78
Description
A vulnerability in the CLI of Cisco FXOS Software could allow an authenticated, local attacker to execute arbitrary commands on the underlying Linux operating system with a privilege level of root on an affected device. The vulnerability is due to insufficient validation of arguments passed to a specific CLI command on the affected device. An attacker could exploit this vulnerability by including malicious input as the argument of an affected command. A successful exploit could allow the attacker to execute arbitrary commands on the underlying Linux operating system with root privileges. An attacker would need valid administrator credentials to exploit this vulnerability.
Affected products
- Cisco Firepower Extensible Operating System (FXOS): from 2.2 before 2.2.2.97; from 2.3 before 2.3.1.144; from 2.4 before 2.4.1.234 — fixed in 2.2.2.97, 2.3.1.144, 2.4.1.234
How to fix
Upgrade to a fixed version: Cisco Firepower Extensible Operating System (FXOS) 2.2.2.97, 2.3.1.144, 2.4.1.234. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20200226-fpwr-cmdinj
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20200226-fpwr-cmdinj
Get alerted when CVE-2020-3169 or the next vulnerability affects your stack