What’s Vulnerable › Vulnerabilities
CVE-2020-3170: Cisco NX-OS Software NX-API Denial of Service Vulnerability
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-02-26 · updated 2026-06-17
- Weakness: CWE-20
Description
A vulnerability in the NX-API feature of Cisco NX-OS Software could allow an unauthenticated, remote attacker to cause an NX-API system process to unexpectedly restart. The vulnerability is due to incorrect validation of the HTTP header of a request that is sent to the NX-API. An attacker could exploit this vulnerability by sending a crafted HTTP request to the NX-API on an affected device. A successful exploit could allow the attacker to cause a denial of service (DoS) condition in the NX-API service; however, the Cisco NX-OS device itself would still be available and passing network traffic. Note: The NX-API feature is disabled by default.
Affected products
- Cisco NX-OS: before 8.4\(1\); before 8.2\(5\) — fixed in 8.2\(5\), 8.4\(1\)
How to fix
Upgrade to a fixed version: Cisco NX-OS 8.2\(5\), 8.4\(1\). Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20200226-nxos-api-dos
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20200226-nxos-api-dos
Get alerted when CVE-2020-3170 or the next vulnerability affects your stack