What’s Vulnerable › Vulnerabilities
CVE-2020-3267: Cisco Unified Contact Center Express Improper API Authorization Vulnerability
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-03 · updated 2026-06-17
- Weakness: CWE-285
Description
A vulnerability in the API subsystem of Cisco Unified Contact Center Express (Unified CCX) could allow an authenticated, remote attacker to change the availability state of any agent. The vulnerability is due to insufficient authorization enforcement on an affected system. An attacker could exploit this vulnerability by authenticating to an affected system with valid agent credentials and performing a specific API call with crafted input. A successful exploit could allow the attacker to change the availability state of an agent, potentially causing a denial of service condition.
Affected products
- Cisco Unified Contact Center Express: before 12.5\(1\) — fixed in 12.5\(1\)
How to fix
Upgrade to a fixed version: Cisco Unified Contact Center Express 12.5\(1\). Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-uccx-api-auth-WSx4v7sB
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-uccx-api-auth-WSx4v7sB
Get alerted when CVE-2020-3267 or the next vulnerability affects your stack