What’s Vulnerable › Vulnerabilities
CVE-2020-3280: Cisco Unified Contact Center Express Remote Code Execution Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-05-22 · updated 2026-06-17
- Weakness: CWE-20
Description
A vulnerability in the Java Remote Management Interface of Cisco Unified Contact Center Express (Unified CCX) could allow an unauthenticated, remote attacker to execute arbitrary code on an affected device. The vulnerability is due to insecure deserialization of user-supplied content by the affected software. An attacker could exploit this vulnerability by sending a malicious serialized Java object to a specific listener on an affected system. A successful exploit could allow the attacker to execute arbitrary code as the root user on an affected device.
Affected products
- Cisco Unified Contact Center Express: from 12.0 before 12.0\(1\)es03 — fixed in 12.0\(1\)es03
How to fix
Upgrade to a fixed version: Cisco Unified Contact Center Express 12.0\(1\)es03. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-uccx-rce-GMSC6RKN
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-uccx-rce-GMSC6RKN
Get alerted when CVE-2020-3280 or the next vulnerability affects your stack