What’s Vulnerable › Vulnerabilities
CVE-2020-3305: Cisco Adaptive Security Appliance Software and Firepower Threat Defense Software BGP Denial of Service Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-05-06 · updated 2026-08-11
- Weakness: CWE-400
Description
A vulnerability in the implementation of the Border Gateway Protocol (BGP) module in Cisco Adaptive Security Appliance (ASA) Software and Cisco Firepower Threat Defense (FTD) Software could allow an unauthenticated, remote attacker to cause a denial of service (DoS) condition. The vulnerability is due to incorrect processing of certain BGP packets. An attacker could exploit this vulnerability by sending a crafted BGP packet. A successful exploit could allow the attacker to cause a DoS condition on the affected device.
Affected products
- Cisco Adaptive Security Appliance: before 9.6.4.36 — fixed in 9.6.4.36
- Cisco ASA Software: from 9.7 before 9.8.4.10; from 9.9 before 9.10.1.30; from 9.12 before 9.12.2.9 — fixed in 9.10.1.30, 9.12.2.9, 9.8.4.10
- Cisco Firepower Threat Defense Software: before 6.3.0.5; from 6.4.0 before 6.4.0.6 — fixed in 6.3.0.5, 6.4.0.6
How to fix
Upgrade to a fixed version: Cisco Adaptive Security Appliance 9.6.4.36; Cisco ASA Software 9.10.1.30, 9.12.2.9, 9.8.4.10; Cisco Firepower Threat Defense Software 6.3.0.5, 6.4.0.6. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-asa-dos-P43GCE5j
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-asa-dos-P43GCE5j
Get alerted when CVE-2020-3305 or the next vulnerability affects your stack