What’s Vulnerable › Vulnerabilities
CVE-2020-3335: Cisco Application Services Engine Software Authorization Vulnerability
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-03 · updated 2026-06-17
- Weakness: CWE-306
Description
A vulnerability in the key store of Cisco Application Services Engine Software could allow an authenticated, local attacker to read sensitive information of other users on an affected device. The vulnerability is due to insufficient authorization limitations. An attacker could exploit this vulnerability by logging in to an affected device locally with valid credentials. A successful exploit could allow the attacker to read the sensitive information of other users on the affected device.
Affected products
- Cisco Application Policy Infrastructure Controller (APIC): 1.1(0c)
- Cisco Application Services Engine: before 1.1.2.20 — fixed in 1.1.2.20
How to fix
Upgrade to a fixed version: Cisco Application Services Engine 1.1.2.20. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-APIC-KSV-3wzbHYT4
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-APIC-KSV-3wzbHYT4
Get alerted when CVE-2020-3335 or the next vulnerability affects your stack