What’s Vulnerable › Vulnerabilities
CVE-2020-3340: Cisco Identity Services Engine Stored Cross-Site Scripting Vulnerabilities
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-07-02 · updated 2026-06-17
- Weakness: CWE-79
Description
Multiple vulnerabilities in the web-based management interface of Cisco Identity Services Engine (ISE) could allow an authenticated, remote attacker with administrative credentials to conduct a cross-site scripting (XSS) attack against a user of the interface. These vulnerabilities are due to insufficient validation of user-supplied input that is processed by the web-based management interface. An attacker could exploit these vulnerabilities by injecting malicious code into specific pages of the interface. A successful exploit could allow the attacker to execute arbitrary script code in the context of the interface or access sensitive, browser-based information. To exploit these vulnerabilities, an attacker would need valid administrative credentials.
Affected products
- Cisco Identity Services Engine: before 2.6.0; 2.6.0, 2.6.0-patch1, 2.6.0-patch2, 2.6.0-patch3, 2.6.0-patch5, 2.6.0-patch6 — fixed in 2.6.0
How to fix
Upgrade to a fixed version: Cisco Identity Services Engine 2.6.0. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-mlt-ise-strd-xss-nqFhTtx7
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-mlt-ise-strd-xss-nqFhTtx7
Get alerted when CVE-2020-3340 or the next vulnerability affects your stack