What’s Vulnerable › Vulnerabilities
CVE-2020-3387: Cisco SD-WAN vManage Software Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 13.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-07-16 · updated 2026-06-17
- Weakness: CWE-20
Description
A vulnerability in Cisco SD-WAN vManage Software could allow an authenticated, remote attacker to execute code with root privileges on an affected system. The vulnerability is due to insufficient input sanitization during user authentication processing. An attacker could exploit this vulnerability by sending a crafted response to the Cisco SD-WAN vManage Software. A successful exploit could allow the attacker to access the software and execute commands they should not be authorized to execute.
Affected products
- Cisco SD-WAN vManage: through 18.3.0; from 18.4.0 before 19.2.3; from 19.3.0 before 20.1.1.1 — fixed in 19.2.3, 20.1.1.1
How to fix
Upgrade to a fixed version: Cisco SD-WAN vManage 19.2.3, 20.1.1.1. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/162958/Cisco-SD-WAN-vManage-19.2.2-Remote-Root.html
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-vmanrce-4jtWT28P
- http://packetstormsecurity.com/files/162958/Cisco-SD-WAN-vManage-19.2.2-Remote-Root.html
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-vmanrce-4jtWT28P
Get alerted when CVE-2020-3387 or the next vulnerability affects your stack