What’s Vulnerable › Vulnerabilities
CVE-2020-3388: Cisco SD-WAN vManage Software Command Injection Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-07-16 · updated 2026-06-17
- Weakness: CWE-287
Description
A vulnerability in the CLI of Cisco SD-WAN vManage Software could allow an authenticated, local attacker to inject arbitrary commands that are executed with root privileges. The vulnerability is due to insufficient input validation. An attacker could exploit this vulnerability by authenticating to the device and submitting crafted input to the CLI. The attacker must be authenticated to access the CLI. A successful exploit could allow the attacker to execute commands with root privileges.
Affected products
- Cisco SD-WAN vManage: through 18.3.0; from 18.4.0 before 19.2.2; from 19.3.0 before 20.1.1 — fixed in 19.2.2, 20.1.1
How to fix
Upgrade to a fixed version: Cisco SD-WAN vManage 19.2.2, 20.1.1. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-clibypvman-sKcLf2L
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-clibypvman-sKcLf2L
Get alerted when CVE-2020-3388 or the next vulnerability affects your stack