What’s Vulnerable › Vulnerabilities
CVE-2020-3459: Cisco FXOS Software for Firepower 4100/9300 Series Command Injection Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-10-21 · updated 2026-06-17
- Weakness: CWE-78
Description
A vulnerability in the CLI of Cisco FXOS Software could allow an authenticated, local attacker to inject arbitrary commands that are executed with root privileges. The vulnerability is due to insufficient input validation of commands supplied by the user. An attacker could exploit this vulnerability by authenticating to a device and submitting crafted input to the affected command. A successful exploit could allow the attacker to execute commands on the underlying operating system with root privileges.
Affected products
- Cisco Firepower Extensible Operating System (FXOS): before 2.4.1.266; from 2.6 before 2.6.1.204; from 2.7 before 2.7.1.131; from 2.8 before 2.8.1.125 — fixed in 2.4.1.266, 2.6.1.204, 2.7.1.131, 2.8.1.125
How to fix
Upgrade to a fixed version: Cisco Firepower Extensible Operating System (FXOS) 2.4.1.266, 2.6.1.204, 2.7.1.131, 2.8.1.125. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-fxos-cmdinj-b63rwKPm
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-fxos-cmdinj-b63rwKPm
Get alerted when CVE-2020-3459 or the next vulnerability affects your stack