What’s Vulnerable › Vulnerabilities
CVE-2020-3470: Cisco Integrated Management Controller Multiple Remote Code Execution Vulnerabilities
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-11-18 · updated 2026-06-17
- Weakness: CWE-119
Description
Multiple vulnerabilities in the API subsystem of Cisco Integrated Management Controller (IMC) could allow an unauthenticated, remote attacker to execute arbitrary code with root privileges. The vulnerabilities are due to improper boundary checks for certain user-supplied input. An attacker could exploit these vulnerabilities by sending a crafted HTTP request to the API subsystem of an affected system. When this request is processed, an exploitable buffer overflow condition may occur. A successful exploit could allow the attacker to execute arbitrary code with root privileges on the underlying operating system (OS).
Affected products
- Cisco Enterprise NFV Infrastructure Software: before 4.4.1 — fixed in 4.4.1
- Cisco Integrated Management Controller (IMC) Supervisor: from 4.0\(1a\) through 4.0\(4l\); from 3.0\(1c\) through 3.0\(4q\); from 4.0\(1a\) through 4.0\(2l\); from 4.1\(1c\) through 4.1\(1f\); before 3.2.11.3; from 3.1 through 4.0\(4l\) — fixed in 3.2.11.3
How to fix
Upgrade to a fixed version: Cisco Enterprise NFV Infrastructure Software 4.4.1; Cisco Integrated Management Controller (IMC) Supervisor 3.2.11.3. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ucs-api-rce-UXwpeDHd
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ucs-api-rce-UXwpeDHd
Get alerted when CVE-2020-3470 or the next vulnerability affects your stack