What’s Vulnerable › Vulnerabilities
CVE-2020-35121
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-15 · updated 2026-06-17
Description
An issue was discovered in the Keysight Database Connector plugin before 1.5.0 for Confluence. A malicious user could insert arbitrary JavaScript into saved macro parameters that would execute when a user viewed a page with that instance of the macro.
Affected products
- Keysight Database Connector: before 1.5.0 — fixed in 1.5.0
How to fix
Upgrade to a fixed version: Keysight Database Connector 1.5.0. Check the vendor advisory for mitigations.
References
- https://bitbucket.org/keysight/keysight-plugins-for-atlassian-products/wiki/Confluence%20Plugins/Database%20Plugin
- https://bitbucket.org/keysight/keysight-plugins-for-atlassian-products/wiki/Confluence%20Plugins/Database%20Plugin
Get alerted when CVE-2020-35121 or the next vulnerability affects your stack