What’s Vulnerable › Vulnerabilities
CVE-2020-35128
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-01-19 · updated 2026-06-17
- Weakness: CWE-79
Description
Mautic before 3.2.4 is affected by stored XSS. An attacker with permission to manage companies, an application feature, could attack other users, including administrators. For example, by loading an externally crafted JavaScript file, an attacker could eventually perform actions as the target user. These actions include changing the user passwords, altering user or email addresses, or adding a new administrator to the system.
Affected products
- Mautic: from 2.0.0 before 2.16.5; from 3.2.0 before 3.2.4 — fixed in 2.16.5, 3.2.4
How to fix
Upgrade to a fixed version: Mautic 2.16.5, 3.2.4. Check the vendor advisory for mitigations.
References
- https://forum.mautic.org/c/announcements/16
- https://forum.mautic.org/t/security-release-for-all-versions-of-mautic-prior-to-2-16-5-and-3-2-4/17786
- https://labs.bishopfox.com/advisories/mautic-version-3.2.2
- https://forum.mautic.org/c/announcements/16
- https://forum.mautic.org/t/security-release-for-all-versions-of-mautic-prior-to-2-16-5-and-3-2-4/17786
- https://labs.bishopfox.com/advisories/mautic-version-3.2.2
Get alerted when CVE-2020-35128 or the next vulnerability affects your stack