What’s Vulnerable › Vulnerabilities
CVE-2020-35129
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-01-19 · updated 2026-06-17
- Weakness: CWE-79
Description
Mautic before 3.2.4 is affected by stored XSS. An attacker with access to Social Monitoring, an application feature, could attack other users, including administrators. For example, an attacker could load an externally drafted JavaScript file that would allow them to eventually perform actions on the target user’s behalf, including changing the user’s password or email address or changing the attacker’s user role from a low-privileged user to an administrator account.
Affected products
- Mautic: before 3.2.4 — fixed in 3.2.4
How to fix
Upgrade to a fixed version: Mautic 3.2.4. Check the vendor advisory for mitigations.
References
- https://forum.mautic.org/c/announcements/16
- https://labs.bishopfox.com/advisories/mautic-version-3.2.2
- https://forum.mautic.org/c/announcements/16
- https://labs.bishopfox.com/advisories/mautic-version-3.2.2
Get alerted when CVE-2020-35129 or the next vulnerability affects your stack