What’s Vulnerable › Vulnerabilities
CVE-2020-3516: Cisco IOS XE Software Web UI Improper Input Validation Vulnerability
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-09-24 · updated 2026-06-17
- Weakness: CWE-20
Description
A vulnerability in the web server authentication of Cisco IOS XE Software could allow an authenticated, remote attacker to crash the web server on the device. The vulnerability is due to insufficient input validation during authentication. An attacker could exploit this vulnerability by entering unexpected characters during a valid authentication. A successful exploit could allow the attacker to crash the web server on the device, which must be manually recovered by disabling and re-enabling the web server.
Affected products
- Cisco IOS XE: before 16.9.6; from 16.12.0 before 16.12.2; from 17.1.0 before 17.1.1; 17.2.1 — fixed in 16.12.2, 16.9.6, 17.1.1
How to fix
Upgrade to a fixed version: Cisco IOS XE 16.12.2, 16.9.6, 17.1.1. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-WEB-UI-exNFmcPO
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-WEB-UI-exNFmcPO
Get alerted when CVE-2020-3516 or the next vulnerability affects your stack