What’s Vulnerable › Vulnerabilities
CVE-2020-3517: Cisco FXOS and NX-OS Software Cisco Fabric Services Denial of Service Vulnerability
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-27 · updated 2026-06-17
- Weakness: CWE-476
Description
A vulnerability in the Cisco Fabric Services component of Cisco FXOS Software and Cisco NX-OS Software could allow an unauthenticated attacker to cause process crashes, which could result in a denial of service (DoS) condition on an affected device. The attack vector is configuration dependent and could be remote or adjacent. For more information about the attack vector, see the Details section of this advisory. The vulnerability is due to insufficient error handling when the affected software parses Cisco Fabric Services messages. An attacker could exploit this vulnerability by sending malicious Cisco Fabric Services messages to an affected device. A successful exploit could allow the attacker to cause a reload of an affected device, which could result in a DoS condition.
Affected products
- Cisco Firepower Extensible Operating System (FXOS): from 1.1 before 1.1.4.179; from 2.0 before 2.0.1.153; from 2.1 before 2.1.1.86; from 2.2 before 2.2.1.70 — fixed in 1.1.4.179, 2.0.1.153, 2.1.1.86, 2.2.1.70
- Cisco NX-OS: before 3.2\(3o\); from 4.0 before 4.0\(4i\); from 4.1 before 4.1\(1c\); 6.0(2)a3(1), 6.0(2)a3(2), 6.0(2)a3(4), 6.0(2)a4(1), 6.0(2)a4(2), 6.0(2)a4(3) (+277) — fixed in 3.2\(3o\), 4.0\(4i\), 4.1\(1c\)
How to fix
Upgrade to a fixed version: Cisco Firepower Extensible Operating System (FXOS) 1.1.4.179, 2.0.1.153, 2.1.1.86, 2.2.1.70; Cisco NX-OS 3.2\(3o\), 4.0\(4i\), 4.1\(1c\). Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-fxos-nxos-cfs-dos-dAmnymbd
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-fxos-nxos-cfs-dos-dAmnymbd
Get alerted when CVE-2020-3517 or the next vulnerability affects your stack