What’s Vulnerable › Vulnerabilities
CVE-2020-35186
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-17 · updated 2026-06-17
- Weakness: CWE-306
Description
The official adminer docker images before 4.7.0-fastcgi contain a blank password for a root user. System using the adminer docker container deployed by affected versions of the docker image may allow a remote attacker to achieve root access with a blank password.
Affected products
- Docker Adminer: from 4.2.5-fastcgi before 4.7.0-fastcgi — fixed in 4.7.0-fastcgi
How to fix
Upgrade to a fixed version: Docker Adminer 4.7.0-fastcgi. Check the vendor advisory for mitigations.
References
- https://github.com/koharin/koharin2/blob/main/CVE-2020-35186
- https://github.com/koharin/koharin2/blob/main/CVE-2020-35186
Get alerted when CVE-2020-35186 or the next vulnerability affects your stack