What’s Vulnerable › Vulnerabilities
CVE-2020-35195
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-17 · updated 2026-06-17
- Weakness: CWE-306
Description
The official haproxy docker images before 1.8.18-alpine (Alpine specific) contain a blank password for a root user. System using the haproxy docker container deployed by affected versions of the docker image may allow a remote attacker to achieve root access with a blank password.
Affected products
- Docker Haproxy Docker Image: before 1.8.18 — fixed in 1.8.18
How to fix
Upgrade to a fixed version: Docker Haproxy Docker Image 1.8.18. Check the vendor advisory for mitigations.
References
- https://github.com/koharin/koharin2/blob/main/CVE-2020-35195
- https://github.com/koharin/koharin2/blob/main/CVE-2020-35195
Get alerted when CVE-2020-35195 or the next vulnerability affects your stack