What’s Vulnerable › Vulnerabilities
CVE-2020-35370
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-12-23 · updated 2026-06-17
- Weakness: CWE-22
Description
A RCE vulnerability exists in Raysync below 3.3.3.8. An unauthenticated unauthorized attacker sending a specifically crafted request to override the specific file in server with malicious content can login as "admin", then to modify specific shell file to achieve remote code execution(RCE) on the hosting server.
Affected products
- Raysync: before 3.3.3.8 — fixed in 3.3.3.8
How to fix
Upgrade to a fixed version: Raysync 3.3.3.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2020-35370 or the next vulnerability affects your stack