What’s Vulnerable › Vulnerabilities
CVE-2020-35457
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-12-14 · updated 2026-06-17
- Weakness: CWE-190
Description
GNOME GLib before 2.65.3 has an integer overflow, that might lead to an out-of-bounds write, in g_option_group_add_entries. NOTE: the vendor's position is "Realistically this is not a security issue. The standard pattern is for callers to provide a static list of option entries in a fixed number of calls to g_option_group_add_entries()." The researcher states that this pattern is undocumented
Affected products
- GNOME GLib: before 2.65.3 — fixed in 2.65.3
How to fix
Upgrade to a fixed version: GNOME GLib 2.65.3. Check the vendor advisory for mitigations.
References
- https://gitlab.gnome.org/GNOME/glib/-/commit/63c5b62f0a984fac9a9700b12f54fe878e016a5d
- https://gitlab.gnome.org/GNOME/glib/-/issues/2197
- https://gitlab.gnome.org/GNOME/glib/-/releases/2.65.3
- https://gitlab.gnome.org/GNOME/glib/-/commit/63c5b62f0a984fac9a9700b12f54fe878e016a5d
- https://gitlab.gnome.org/GNOME/glib/-/issues/2197
- https://gitlab.gnome.org/GNOME/glib/-/releases/2.65.3
Get alerted when CVE-2020-35457 or the next vulnerability affects your stack