What’s Vulnerable › Vulnerabilities
CVE-2020-35470
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-15 · updated 2026-06-17
Description
Envoy before 1.16.1 logs an incorrect downstream address because it considers only the directly connected peer, not the information in the proxy protocol header. This affects situations with tcp-proxy as the network filter (not HTTP filters).
Affected products
- envoyproxy envoy: before 1.16.1 — fixed in 1.16.1
How to fix
Upgrade to a fixed version: envoyproxy envoy 1.16.1. Check the vendor advisory for mitigations.
References
- https://github.com/envoyproxy/envoy/compare/v1.16.0...v1.16.1
- https://github.com/envoyproxy/envoy/issues/14087
- https://github.com/envoyproxy/envoy/pull/14131
- https://github.com/envoyproxy/envoy/compare/v1.16.0...v1.16.1
- https://github.com/envoyproxy/envoy/issues/14087
- https://github.com/envoyproxy/envoy/pull/14131
Get alerted when CVE-2020-35470 or the next vulnerability affects your stack