What’s Vulnerable › Vulnerabilities
CVE-2020-35475
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-18 · updated 2026-06-17
- Weakness: CWE-79
Description
In MediaWiki before 1.35.1, the messages userrights-expiry-current and userrights-expiry-none can contain raw HTML. XSS can happen when a user visits Special:UserRights but does not have rights to change all userrights, and the table on the left side has unchangeable groups in it. (The right column with the changeable groups is not affected and is escaped correctly.)
Affected products
- Debian Linux: 10.0
- Fedoraproject Fedora: 33
- Wikimedia Foundation MediaWiki: before 1.35.1 — fixed in 1.35.1
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.35.1. Check the vendor advisory for mitigations.
References
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/STT5Z4A3BCXVH3WIPICWU2FP4IPIMUPC/
- https://lists.wikimedia.org/pipermail/mediawiki-announce/2020-December/000268.html
- https://phabricator.wikimedia.org/T268917
- https://www.debian.org/security/2020/dsa-4816
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/STT5Z4A3BCXVH3WIPICWU2FP4IPIMUPC/
- https://lists.wikimedia.org/pipermail/mediawiki-announce/2020-December/000268.html
- https://phabricator.wikimedia.org/T268917
- https://www.debian.org/security/2020/dsa-4816
Get alerted when CVE-2020-35475 or the next vulnerability affects your stack