What’s Vulnerable › Vulnerabilities
CVE-2020-35502
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-25 · updated 2026-06-17
- Weakness: CWE-401
Description
A flaw was found in Privoxy in versions before 3.0.29. Memory leaks when a response is buffered and the buffer limit is reached or Privoxy is running out of memory can lead to a system crash.
Affected products
- privoxy: before 3.0.29 — fixed in 3.0.29
How to fix
Upgrade to a fixed version: privoxy 3.0.29. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1928749
- https://security.gentoo.org/glsa/202107-16
- https://www.privoxy.org/3.0.29/user-manual/whatsnew.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1928749
- https://security.gentoo.org/glsa/202107-16
- https://www.privoxy.org/3.0.29/user-manual/whatsnew.html
Get alerted when CVE-2020-35502 or the next vulnerability affects your stack