What’s Vulnerable › Vulnerabilities
CVE-2020-35573
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-20 · updated 2026-06-17
- Weakness: CWE-834
Description
srs2.c in PostSRSd before 1.10 allows remote attackers to cause a denial of service (CPU consumption) via a long timestamp tag in an SRS address.
Affected products
- Debian Linux: 9.0
- Postsrsd Project Postsrsd: before 1.10 — fixed in 1.10
How to fix
Upgrade to a fixed version: Postsrsd Project Postsrsd 1.10. Check the vendor advisory for mitigations.
References
- https://github.com/roehling/postsrsd/commit/4733fb11f6bec6524bb8518c5e1a699288c26bac
- https://lists.debian.org/debian-lts-announce/2020/12/msg00031.html
- https://security.gentoo.org/glsa/202107-08
- https://github.com/roehling/postsrsd/commit/4733fb11f6bec6524bb8518c5e1a699288c26bac
- https://lists.debian.org/debian-lts-announce/2020/12/msg00031.html
- https://security.gentoo.org/glsa/202107-08
Get alerted when CVE-2020-35573 or the next vulnerability affects your stack