What’s Vulnerable › Vulnerabilities
CVE-2020-35650
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-23 · updated 2026-06-17
- Weakness: CWE-79
Description
Multiple cross-site scripting (XSS) vulnerabilities in Uncanny Groups for LearnDash before v3.7 allow authenticated remote attackers to inject arbitrary JavaScript or HTML via the ulgm_code_redeem POST Parameter in user-code-redemption.php, the ulgm_user_first POST Parameter in user-registration-form.php, the ulgm_user_last POST Parameter in user-registration-form.php, the ulgm_user_email POST Parameter in user-registration-form.php, the ulgm_code_registration POST Parameter in user-registration-form.php, the ulgm_terms_conditions POST Parameter in user-registration-form.php, the _ulgm_total_seats POST Parameter in frontend-uo_groups_buy_courses.php, the uncanny_group_signup_user_first POST Parameter in group-registration-form.php, the uncanny_group_signup_user_last POST Parameter in group-registration-form.php, the uncanny_group_signup_user_login POST Parameter in group-registration-form.php, the uncanny_group_signup_user_email POST Parameter in group-registration-form.php, the success-invited GET Parameter in frontend-uo_groups.php, the bulk-errors GET Parameter in frontend-uo_groups.php, or the message GET Parameter in frontend-uo_groups.php.
Affected products
- Uncanny Owl Uncanny Groups for LearnDash: before 3.7 — fixed in 3.7
How to fix
Upgrade to a fixed version: Uncanny Owl Uncanny Groups for LearnDash 3.7. Check the vendor advisory for mitigations.
References
- https://gist.github.com/michiiii/81d801f563138abe7da61e2d95342202
- https://www.uncannyowl.com/knowledge-base/uncanny-learndash-groups-changelog/
- https://gist.github.com/michiiii/81d801f563138abe7da61e2d95342202
- https://www.uncannyowl.com/knowledge-base/uncanny-learndash-groups-changelog/
Get alerted when CVE-2020-35650 or the next vulnerability affects your stack