What’s Vulnerable › Vulnerabilities
CVE-2020-35700
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-02-08 · updated 2026-06-17
- Weakness: CWE-89
Description
A second-order SQL injection issue in Widgets/TopDevicesController.php (aka the Top Devices dashboard widget) of LibreNMS before 21.1.0 allows remote authenticated attackers to execute arbitrary SQL commands via the sort_order parameter against the /ajax/form/widget-settings endpoint.
Affected products
- librenms: before 21.1.0 — fixed in 21.1.0
How to fix
Upgrade to a fixed version: librenms 21.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/blob/master/app/Http/Controllers/Widgets/TopDevicesController.php
- https://github.com/librenms/librenms/issues/12405
- https://github.com/librenms/librenms/pull/12422
- https://github.com/librenms/librenms/releases/tag/21.1.0
- https://www.horizon3.ai/disclosures/librenms-second-order-sqli
- https://github.com/librenms/librenms/blob/master/app/Http/Controllers/Widgets/TopDevicesController.php
- https://github.com/librenms/librenms/issues/12405
- https://github.com/librenms/librenms/pull/12422
- https://github.com/librenms/librenms/releases/tag/21.1.0
- https://www.horizon3.ai/disclosures/librenms-second-order-sqli
Get alerted when CVE-2020-35700 or the next vulnerability affects your stack