What’s Vulnerable › Vulnerabilities
CVE-2020-35716
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-12-26 · updated 2026-06-17
Description
Belkin LINKSYS RE6500 devices before 1.0.012.001 allow remote attackers to cause a persistent denial of service (segmentation fault) via a long /goform/langSwitch langSelectionOnly parameter.
Affected products
- Linksys Re6500 Firmware: before 1.0.012.001 — fixed in 1.0.012.001
How to fix
Upgrade to a fixed version: Linksys Re6500 Firmware 1.0.012.001. Check the vendor advisory for mitigations.
References
- https://bugcrowd.com/disclosures/72d7246b-f77f-4f7f-9bd1-fdc35663cc92/linksys-re6500-unauthenticated-rce-working-across-multiple-fw-versions
- https://downloads.linksys.com/support/assets/releasenotes/ExternalReleaseNotes_RE6500_1.0.012.001.txt
- https://resolverblog.blogspot.com/2020/07/linksys-re6500-unauthenticated-rce-full.html
- https://bugcrowd.com/disclosures/72d7246b-f77f-4f7f-9bd1-fdc35663cc92/linksys-re6500-unauthenticated-rce-working-across-multiple-fw-versions
- https://downloads.linksys.com/support/assets/releasenotes/ExternalReleaseNotes_RE6500_1.0.012.001.txt
- https://resolverblog.blogspot.com/2020/07/linksys-re6500-unauthenticated-rce-full.html
Get alerted when CVE-2020-35716 or the next vulnerability affects your stack