What’s Vulnerable › Vulnerabilities

CVE-2020-35799

Description

Certain NETGEAR devices are affected by a stack-based buffer overflow by an unauthenticated attacker. This affects D3600 before 1.0.0.76, D6000 before 1.0.0.78, D6200 before 1.1.00.32, D7000 before 1.0.1.68, D7800 before 1.0.1.56, DM200 before 1.0.0.61, EX2700 before 1.0.1.52, EX6100v2 before 1.0.1.76, EX6150v2 before 1.0.1.76, EX6200v2 before 1.0.1.74, EX6400 before 1.0.2.140, EX7300 before 1.0.2.140, EX8000 before 1.0.1.186, JR6150 before 1.0.1.18, PR2000 before 1.0.0.28, R6020 before 1.0.0.38, R6050 before 1.0.1.18, R6080 before 1.0.0.38, R6120 before 1.0.0.46, R6220 before 1.1.0.80, R6230 before 1.1.0.80, R6260 before 1.1.0.40, R6700v2 before 1.2.0.36, R6800 before 1.2.0.36, R6900v2 before 1.2.0.36, R7500v2 before 1.0.3.40, R7800 before 1.0.2.62, R8900 before 1.0.4.12, R9000 before 1.0.4.12, RBK20 before 2.3.0.28, RBR20 before 2.3.0.28, RBS20 before 2.3.0.28, RBK40 before 2.3.0.28, RBR40 before 2.3.0.28, RBS40 before 2.3.0.28, RBK50 before 2.3.0.32, RBR50 before 2.3.0.32, RBS50 before 2.3.0.32, WN2000RPTv3 before 1.0.1.34, WN3000RPv2 before 1.0.0.78, WN3000RPv2 before 1.0.0.78, WN3000RPv3 before 1.0.2.78, WN3100RPv2 before 1.0.0.66, WNR2000v5 before 1.0.0.70, WNR2020 before 1.1.0.62, XR450 before 2.3.2.32, and XR500 before 2.3.2.32.

Affected products

How to fix

Upgrade to a fixed version: NETGEAR D3600 Firmware 1.0.0.76; NETGEAR D6000 Firmware 1.0.078; NETGEAR D6200 Firmware 1.1.00.32; NETGEAR D7000 Firmware 1.0.1.68; NETGEAR D7800 Firmware 1.0.1.56; NETGEAR Dm200 Firmware 1.0.0.61; NETGEAR Ex2700 Firmware 1.0.1.52; NETGEAR Ex6100V2 Firmware 1.0.1.76; NETGEAR Ex6150V2 Firmware 1.0.1.76; NETGEAR Ex6200V2 Firmware 1.0.1.74; NETGEAR Ex6400 Firmware 1.0.2.140; NETGEAR Ex7300 Firmware 1.0.2.140. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2020-35799 or the next vulnerability affects your stack