What’s Vulnerable › Vulnerabilities
CVE-2020-35808
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-30 · updated 2026-06-17
- Weakness: CWE-79
Description
Certain NETGEAR devices are affected by stored XSS. This affects D6100 before 1.0.0.63, DM200 before 1.0.0.61, R7800 before 1.0.2.52, R8900 before 1.0.4.12, R9000 before 1.0.4.12, WN3000RPv2 before 1.0.0.68, and WNR2000v5 before 1.0.0.66.
Affected products
- NETGEAR D6100 Firmware: before 1.0.0.63 — fixed in 1.0.0.63
- NETGEAR Dm200 Firmware: before 1.0.0.61 — fixed in 1.0.0.61
- NETGEAR R7800 Firmware: before 1.0.2.52 — fixed in 1.0.2.52
- NETGEAR R8900 Firmware: before 1.0.4.12 — fixed in 1.0.4.12
- NETGEAR R9000 Firmware: before 1.0.4.12 — fixed in 1.0.4.12
- NETGEAR Wn3000Rpv2 Firmware: before 1.0.0.68 — fixed in 1.0.0.68
- NETGEAR Wnr2000V5 Firmware: before 1.0.0.66 — fixed in 1.0.0.66
How to fix
Upgrade to a fixed version: NETGEAR D6100 Firmware 1.0.0.63; NETGEAR Dm200 Firmware 1.0.0.61; NETGEAR R7800 Firmware 1.0.2.52; NETGEAR R8900 Firmware 1.0.4.12; NETGEAR R9000 Firmware 1.0.4.12; NETGEAR Wn3000Rpv2 Firmware 1.0.0.68; NETGEAR Wnr2000V5 Firmware 1.0.0.66. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000062708/Security-Advisory-for-Stored-Cross-Site-Scripting-on-Some-Routers-and-Range-Extenders-PSV-2018-0158
- https://kb.netgear.com/000062708/Security-Advisory-for-Stored-Cross-Site-Scripting-on-Some-Routers-and-Range-Extenders-PSV-2018-0158
Get alerted when CVE-2020-35808 or the next vulnerability affects your stack