What’s Vulnerable › Vulnerabilities
CVE-2020-35822
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-30 · updated 2026-06-17
- Weakness: CWE-79
Description
Certain NETGEAR devices are affected by stored XSS. This affects D7800 before 1.0.1.56, R7500v2 before 1.0.3.46, R7800 before 1.0.2.74, R8900 before 1.0.4.28, R9000 before 1.0.4.28, RAX120 before 1.0.0.78, XR500 before 2.3.2.56, and XR700 before 1.0.1.10.
Affected products
- NETGEAR D7800 Firmware: before 1.0.1.56 — fixed in 1.0.1.56
- NETGEAR R7500 Firmware: before 1.0.3.46 — fixed in 1.0.3.46
- NETGEAR R7800 Firmware: before 1.0.2.74 — fixed in 1.0.2.74
- NETGEAR R8900 Firmware: before 1.0.4.28 — fixed in 1.0.4.28
- NETGEAR R9000 Firmware: before 1.0.4.28 — fixed in 1.0.4.28
- NETGEAR Rax120 Firmware: before 1.0.0.78 — fixed in 1.0.0.78
- NETGEAR Xr500 Firmware: before 2.3.2.56 — fixed in 2.3.2.56
- NETGEAR Xr700 Firmware: before 1.0.1.10 — fixed in 1.0.1.10
How to fix
Upgrade to a fixed version: NETGEAR D7800 Firmware 1.0.1.56; NETGEAR R7500 Firmware 1.0.3.46; NETGEAR R7800 Firmware 1.0.2.74; NETGEAR R8900 Firmware 1.0.4.28; NETGEAR R9000 Firmware 1.0.4.28; NETGEAR Rax120 Firmware 1.0.0.78; NETGEAR Xr500 Firmware 2.3.2.56; NETGEAR Xr700 Firmware 1.0.1.10. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000062676/Security-Advisory-for-Stored-Cross-Site-Scripting-on-Some-Routers-and-WiFi-Systems-PSV-2018-0498
- https://kb.netgear.com/000062676/Security-Advisory-for-Stored-Cross-Site-Scripting-on-Some-Routers-and-WiFi-Systems-PSV-2018-0498
Get alerted when CVE-2020-35822 or the next vulnerability affects your stack