What’s Vulnerable › Vulnerabilities
CVE-2020-35863
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-31 · updated 2026-06-17
- Weakness: CWE-444
Description
An issue was discovered in the hyper crate before 0.12.34 for Rust. HTTP request smuggling can occur. Remote code execution can occur in certain situations with an HTTP server on the loopback interface.
Affected products
- hyperium hyper: before 0.12.34 — fixed in 0.12.34
How to fix
Upgrade to a fixed version: hyperium hyper 0.12.34. Check the vendor advisory for mitigations.
References
- https://rustsec.org/advisories/RUSTSEC-2020-0008.html
- https://rustsec.org/advisories/RUSTSEC-2020-0008.html
Get alerted when CVE-2020-35863 or the next vulnerability affects your stack