What’s Vulnerable › Vulnerabilities
CVE-2020-35909
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-31 · updated 2026-06-17
Description
An issue was discovered in the multihash crate before 0.11.3 for Rust. The from_slice parsing code can panic via unsanitized data from a network server.
Affected products
- Protocol Multihash: before 0.11.3 — fixed in 0.11.3
How to fix
Upgrade to a fixed version: Protocol Multihash 0.11.3. Check the vendor advisory for mitigations.
References
- https://rustsec.org/advisories/RUSTSEC-2020-0068.html
- https://rustsec.org/advisories/RUSTSEC-2020-0068.html
Get alerted when CVE-2020-35909 or the next vulnerability affects your stack