What’s Vulnerable › Vulnerabilities
CVE-2020-35911
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-31 · updated 2026-06-17
- Weakness: CWE-362
Description
An issue was discovered in the lock_api crate before 0.4.2 for Rust. A data race can occur because of MappedRwLockReadGuard unsoundness.
Affected products
- Lock Api Project Lock Api: before 0.4.2 — fixed in 0.4.2
How to fix
Upgrade to a fixed version: Lock Api Project Lock Api 0.4.2. Check the vendor advisory for mitigations.
References
- https://rustsec.org/advisories/RUSTSEC-2020-0070.html
- https://rustsec.org/advisories/RUSTSEC-2020-0070.html
Get alerted when CVE-2020-35911 or the next vulnerability affects your stack