What’s Vulnerable › Vulnerabilities
CVE-2020-35932
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-01-01 · updated 2026-06-17
- Weakness: CWE-502
Description
Insecure Deserialization in the Newsletter plugin before 6.8.2 for WordPress allows authenticated remote attackers with minimal privileges (such as subscribers) to use the tpnc_render AJAX action to inject arbitrary PHP objects via the options[inline_edits] parameter. NOTE: exploitability depends on PHP objects that might be present with certain other plugins or themes.
Affected products
- Tribulant Newsletter: before 6.8.2 — fixed in 6.8.2
How to fix
Upgrade to a fixed version: Tribulant Newsletter 6.8.2. Check the vendor advisory for mitigations.
References
- https://www.wordfence.com/blog/2020/08/newsletter-plugin-vulnerabilities-affect-over-300000-sites/
- https://www.wordfence.com/blog/2020/08/newsletter-plugin-vulnerabilities-affect-over-300000-sites/
Get alerted when CVE-2020-35932 or the next vulnerability affects your stack