What’s Vulnerable › Vulnerabilities
CVE-2020-35933
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-01-01 · updated 2026-06-17
- Weakness: CWE-79
Description
A Reflected Authenticated Cross-Site Scripting (XSS) vulnerability in the Newsletter plugin before 6.8.2 for WordPress allows remote attackers to trick a victim into submitting a tnpc_render AJAX request containing either JavaScript in an options parameter, or a base64-encoded JSON string containing JavaScript in the encoded_options parameter.
Affected products
- satollo Newsletter – Send awesome emails from WordPress: before 6.8.2 — fixed in 6.8.2
How to fix
Upgrade to a fixed version: satollo Newsletter – Send awesome emails from WordPress 6.8.2. Check the vendor advisory for mitigations.
References
- https://www.wordfence.com/blog/2020/08/newsletter-plugin-vulnerabilities-affect-over-300000-sites/
- https://www.wordfence.com/blog/2020/08/newsletter-plugin-vulnerabilities-affect-over-300000-sites/
Get alerted when CVE-2020-35933 or the next vulnerability affects your stack